原因分析以及解决办法如下。1、在安装软件过程中系统提示SDK版本过低无法运行,APP可以正常安装,但软件运行时闪退。当前鸿蒙136可以运行,升级到鸿蒙165某些APP开始闪退。2、遇到了相同的提示,可能确实是软件太老了,换其他安卓机上估计打都打不开,同时顺便刷了鸿蒙的全量包,但问题依旧。
  相关参考:用升级模式之eRecovery模式安装鸿蒙HarmonyOS全量包的步骤。3、用的是鸿蒙2。0。0,在运行软件时提示“应用SDK版本过低无法运行”,重新下载再安装都还是同样的提示。4、用的是鸿蒙138版本操作系统,下载了一个游戏风暴特工队2,安装完以后,运行的时候提示“此应用SDK版本过低,无法正常运行”,换了好几个网站,下载不同版本,都是这样的提示。
  5、在鸿蒙系统上安装很多老应用都可能会有“此应用SDK版本过低,无法正常运行,请及时更新或联系开发者”的提示,应该是软件太老旧和鸿蒙系统不兼容了,如果是安装新的应用就没有。